Problem Installing New Activities

Developer
Oct 17, 2011 at 11:31 AM

I have installed the Community TFS Build Activities 1.0.0.6 on several machines without issue. Then yesterday I tried to install version 1.1.0.0 for a client and found I could not add some of the Activities to the toolbox.

We could load some of the DLL's but not all.

For example when we try to add TFSBuildExtensions.Activites.dll to System.Workflow Components we get the message:

System.Exception: There are no components in TFSBuildExtensions.Activites.dll that can be placed on the toolbox. If you are working with the 4.0 based activities then please try the System Activities Components tab.

So we did that and we get the same message but it says to try adding them to System.Workflow.

Any help would be appreciated.

 Dave

Developer
Oct 26, 2011 at 12:17 PM

Hi Dave,

You must add the TFSBuildExtensions.Activities.dll to the System.Activites Components tab. Those are 4.0 based activities.

Guillaume

Dec 26, 2011 at 4:09 PM

Hello Guillaume

I've been able to add those activities to the Toolbox but it was impossible to drag and drop them to the workflow designer.

What I tried was to add them to the GAC (what I usually do with my custom activities), but impossible to do that.

I'm really confused on how to use those activities (in a convenient way...)

Developer
Dec 26, 2011 at 6:22 PM

You need to create a VS project, see the example under Documentation it explains what to do.

http://tfsbuildextensions.codeplex.com/wikipage?title=How%20to%20integrate%20the%20extensions%20into%20a%20build%20template&referringTitle=Documentation