App Pool Name Cannot Be Specified as a Variable?

May 21, 2012 at 10:30 PM

Sorry, I already submitted this as an issue, but I should have created a discussion first to see if I'm doing things correctly.

Here's the issue: http://tfsbuildextensions.codeplex.com/workitem/10785

Here's the text in full in case a moderator wants to delete the issue:

This is probably just a case of a user who doesn't know what he's doing...

For some reason, when using the Web.Iis7AppPool activity, I can use a variable to specify the MachineName, for instance; but I cannot do so for Name.

I tried to edit the xaml and put brackets around the variable name (e.g. [AppPoolName]), but it generates an error ("Invalid application pool name") when the build is run.

I also tried looking at the source (Iis7AppPool.cs and BaseRemoteCodeActivity.cs), to see why this would be so, but nothing is jumping out at me; I don't even have a plausible hypothesis.

Am I doing anything incorrectly, or is this really something that needs to be implemented?