This project is read-only.

TF30063: You are not authorized to access error when using TFSSource when checking out a file

Jan 29, 2013 at 12:06 PM


I use the TFSSource component to checkout a file.

I’ve provided the following properties:

Action: TfsAction.Checkout

Comments: “comments…”

Itemspec: “full path to local mapped file”

ToolPath: “full path to tf.exe to the build server”

WorkingDirectory: “path to the same directory for the checked out file”

I use Windows Server 2012 as a build machine and a hosted TFS for source control ( The build is created using VS 2012.

When I ran the build TFSSource displays this error message:

TF30063: You are not authorized to access [HOSTED TFS ULR]


Here is the full stack:



  • ·         TreatWarningsAsErrors: True
  • ·         IgnoreItemAlreadyHasPendingChangesWarning: False
  • ·         Notes:
  • ·         Login:
  • ·         BypassGatedCheckin: False
  • ·         IgnoreExceptions: False
  • ·         FailBuildOnError: False
  • ·         Action: Checkout
  • ·         LogExceptionStack: True
  • ·         OverrideReason:
  • ·         WorkingDirectory: [AS EXPLAINED ABOVE]
  • ·         Collection:
  • ·         Itemspec: [AS EXPLAINED ABOVE]
  • ·         Comments: new file added
  • ·         Recursive: False


  • ·         ReturnCode: 100

Running C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\IDE\TF.exe checkout


TF30063: You are not authorized to access\DefaultCollection.

Local path [MY LOCAL PATH]


I understand that this component is just a wrapper to tf.exe so I tried to narrow down the issue doing the following:

1)       I used InvokeProcess component to a bat file which has a call to tf.exe with the same parameters

"C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\IDE\TF.exe" checkout "[FULL PATH TO THE FILE” /noprompt

And it works ok.

2)       I’ve got a copy of the project from codeplex and updated TfsSource.cs hardcoding the paths and removing ActivityContext and compiled it as a console application. I used InvokeProcess to run this console application and it works as well.

I tried to provide the Login but it didn't help. Also it looks like the Collection property is not supported.

Both checkouts worked under the Account Service account which is one created by hosted TFS.


Is there anything else I need to provide to this component? Is there an issue with the user this extension runs under?




May 23, 2013 at 8:09 PM
I am having the same issue. Any thoughts on how to get this working using the activity?