This project is read-only.

Error TF215097 custom assemblies not found

Jun 24, 2013 at 7:39 AM
I follow the instructions of the documentation, but I have always the same error:

TF215097: An error occurred while initializing a build for build definition \TestProject\xxxxxxxx Main VP:
Exception Message: Could not load file or assembly 'TfsBuildExtensions.Activities, Version=1.11.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. A strongly-named assembly is required. (Exception from HRESULT: 0x80131044) (type FileLoadException)
Exception Stack Trace: at System.Reflection.RuntimeAssembly.GetType(RuntimeAssembly assembly, String name, Boolean throwOnError, Boolean ignoreCase, ObjectHandleOnStack type)
at System.Reflection.RuntimeAssembly.GetType(String name, Boolean throwOnError, Boolean ignoreCase)
at System.Xaml.Schema.XamlNamespace.SearchAssembliesForShortName(String shortName)
at System.Xaml.Schema.XamlNamespace.TryGetType(String typeName)
at System.Xaml.Schema.XamlNamespace.GetXamlType(String typeName, XamlType[] typeArgs)
at System.Xaml.XamlSchemaContext.GetXamlType(String xamlNamespace, String name, XamlType[] typeArguments)
at System.Activities.XamlIntegration.ActivityXamlServices.DynamicActivityReaderSchemaContext.GetXamlType(String xamlNamespace, String name, XamlType[] typeArguments)
at MS.Internal.Xaml.XamlContext.GetXamlType(XamlTypeName typeName, Boolean returnUnknownTypesOnFailure, Boolean skipVisibilityCheck)
at MS.Internal.Xaml.Parser.XamlScanner.ReadObjectElement_Object(String xmlns, String name, XamlScannerNode node)
at MS.Internal.Xaml.Parser.XamlScanner.ReadObjectElement(XamlName name, Boolean isEmptyTag)
at MS.Internal.Xaml.Parser.XamlScanner.DoXmlRead()
at MS.Internal.Xaml.Parser.XamlScanner.Read()
at MS.Internal.Xaml.Parser.XamlPullParser.<P_NonemptyPropertyElement>d__42.MoveNext()
at MS.Internal.Xaml.Parser.XamlPullParser.<P_PropertyElement>d__35.MoveNext()
at MS.Internal.Xaml.Parser.XamlPullParser.<P_ElementBody>d__23.MoveNext()
at MS.Internal.Xaml.Parser.XamlPullParser.<P_Element>d__7.MoveNext()
at MS.Internal.Xaml.Parser.XamlPullParser.<P_ElementContent>d__4a.MoveNext()
at MS.Internal.Xaml.Parser.XamlPullParser.<P_ElementBody>d__23.MoveNext()
at MS.Internal.Xaml.Parser.XamlPullParser.<P_Element>d__7.MoveNext()
at MS.Internal.Xaml.Parser.XamlPullParser.<Parse>d__0.MoveNext()
at MS.Internal.Xaml.NodeStreamSorter.MoveNext()
at System.Xaml.XamlXmlReader.Read()
at System.Activities.XamlIntegration.DynamicActivityXamlReader.Read()
at System.Xaml.XamlServices.Transform(XamlReader xamlReader, XamlWriter xamlWriter, Boolean closeWriter)
at System.Xaml.XamlServices.Load(XamlReader xamlReader)
at System.Activities.XamlIntegration.ActivityXamlServices.Load(XamlReader xamlReader, ActivityXamlServicesSettings settings)
at System.Activities.XamlIntegration.ActivityXamlServices.Load(XmlReader xmlReader, ActivityXamlServicesSettings settings)
...

What I have tested:
  • In the "Build Controller Properties" I have made the definition for the "Version control path to the custom assemblies" correctly.
  • Installed all assemblies to the GAC on Build Server (C:\Windows\Microsoft.NET\assembly\GAC_MSIL...)
  • The custom assemblies are transfered correctly to the Build Server to folder: c:\users\<User>\AppData\Local\Temp\BuildController\<BuildController No.>\Assemblies
My configuration
TFS: 2012
Build Server: Win 7 64bit

Any ideas?

Thanks
Urs